Fix ‘Saved/Secured’ Wifi connection issues on Android

Filed in Mobile 12 comments

The other day, my dad came to me with his Samsung Galaxy S3 phone with an issue that it’s not connecting to the wifi connection at home. The modem had been changed recently but I kept the same SSID and password as the previous one. Funnily, it just didn’t connect. Only his phone had the problem. All the other devices and phones in the house were connecting to the internet, and sharing files with no issues.

The password had been entered correctly, and the connection got ‘SAVED & SECURED’ with full range showing. But it doesn’t just get on it with. On clicking Connect, a faint millisecond of ‘Connecting’ shows up and goes away, and the list refreshes itself.

So I took to figuring out a few steps (tried and tested each before getting one to work) which I have listed below. As this issue can be a common one with people on Android phones in general, one of these steps will help for sure.

STEP ONE – Setting a Static IP

  1. Go to Settings
  2. Tap on Wifi – Make sure this is ON
  3. Tap and hold on the SSID that you are having the issue with
  4. Tap on Modify network settings
  5. Tap on Advanced settings (also available if you tap on ‘forget’ the network and on re-connection)
    1. Here, change DHCP to STATIC
    2. Enter the IP address that is free on the network (192.168.1.15 or something – in the case that the modem is on the 192.168.1.1 range)
    3. Enter DNS as 192.168.1.1 – or as per the range of the server/modem
    4. DNS2 can be given 8.8.8.8
    5. Put in the password
    6. Done!

This would get you connected in most cases. If not, keep reading.

STEP TWO – Enable Airplane Mode

  1. Enable Airplane Mode
  2. Switch on Wifi – connect to the network
  3. Disable Airplane Mode

STEP THREE – Connecting via WPS

This step is a fair and easy way to get connected to the modem. Make sure your modem has the WPS or Wifi Protected Setup button for getting this to work.

  1. Go to Settings on your phone
  2. Tap on Wifi
  3. Tap on the bottom left of the phone for Options. This can differ between brands. Some have the three vertical dots for options, others like Moto would have the options on the right, while other phones would have the options pop up after tapping on a front panel button.
  4. Tap on WPS Push.
  5. The next screen will wait for you to click on the WPS button on the modem. Once the phone figures that you have triggered from the modem side (you have to click on the WPS button on the modem), the connection gets set and you are done.

Are you still reading through? Guess your issue hasn’t resolved as of yet. I hope the next one will provide the fix

STEP FOUR – HIDING THE SSID

  1. Tap on forget network before starting this step
  2. Get over to the modem’s admin page (eg; 192.168.1.1) from your internet browser
  3. Get to the page where the wifi or WLAN settings are entered.
  4. Disable broadcast or HIDE SSID (usually a tickmark to be clicked)
  5. Click Enable or Save and let the modem restart itself (takes a 1 minute or 30 seconds)
  6. Next up, Get to the wifi settings on your phone
  7. Tap on ADD A NEW CONNECTION
  8. Enter the SSID name and password.
  9. DONE! You’re good to go.

One thing I understood from the issue, especially after trying a number of steps above, is that some old modem settings gets stored in a ‘cache’ memory of the phone, and the new settings fail to override it. Usually this is easily fixable when on a desktop on command level. But on a phone, things can seem easy, but tricky to get done with.

If you still haven’t got it resolved, do drop me a message in the comments section below and I will get back to you. On the other hand, if it DID end up working for you, give a positive, a thumbs-up or something, I’m sure it would help the others.

Happy browsing!

Cheers! 🙂

Digg This
Reddit This
Stumble Now!
Buzz This
Vote on DZone
Share on Facebook
Bookmark this on Delicious
Kick It on DotNetKicks.com
Shout it
Share on LinkedIn
Bookmark this on Technorati
Post on Twitter
Google Buzz (aka. Google Reader)
Posted by Arif   @   25 December 2016 12 comments
Tags : , , ,

Share This Post

RSS Digg Twitter StumbleUpon Delicious Technorati

12 Comments

Comments
Dec 25, 2016
7:09 pm
#1 Vijay S Paul :

After almost 3 years, finally! 🙂

Author Dec 28, 2016
6:12 am
#2 Arif :

Thanks for the support, Vijay. 🙂

Feb 26, 2017
6:18 pm
#3 mansou :

Really no one of the steps above work the issue still frustrating me!!

Mar 1, 2017
6:54 pm

i followed the described steps..and it helped me…@ mansou what problem are you facing?

Mar 2, 2017
11:46 pm
#5 Steve M :

I tried as much of this as I could and no help. I cannot mess with the router since it is at my office that I have the issue. My IT guys are swamped so cannot help. My phone, for years, connected fine to this same wifi network, nothing changed at the office and I suddenly got this save,secured issue. Phone still connects fine at home. Not sure what to do.

Mar 16, 2017
10:19 am
#6 sergio :

hello,i tried every step…still doesn’t connect..but to my surprise it had started working for a day..what should i do? ..plz help

Apr 17, 2017
5:36 pm
#7 ishang :

Still cant connect to my Wifi. I have tried all the suggestions still the same problem saved/secured

May 9, 2017
1:16 am
#8 Jim J :

Tried all items listed, still get the saved/secure issue also. I’m taking the damn phone to Verizon tomorrow. This is ridiculous.

May 9, 2017
2:56 am
#9 Jim J :

I was able to find the fix… it was a white labelled mac address I had listed on the router for TV streaming… removed it, problem solved!

May 23, 2017
9:56 pm
#10 gani :

None of the fixes mentioned above helped 🙁
Any other solutions?

Jun 13, 2017
10:44 am
#11 Michael :

Tried all the steps for my tablet, but it didnt work. It will connect no longer than a few seconds and then say saved, secured and disconnect. Thanks for the post though!

Jul 6, 2017
7:39 pm
#12 Akhshayaa :

Hey,

I tried few of these on my phone.
but since i use a wifi app on the pc, the router and interent SSID methods you described.
I had this issue few times before but somehow solved it (i dont remember).
could help with the app type solutions.

I use My Wifi Router 3.0

Thanks

Leave a Comment

Previous Post
«
Next Post
»
EXULT designed by ZENVERSE  |  In conjunction with Reseller Hosting from the #1 Web Hosting Provider - HostNexus.